Workheld Flow Web and Call Web down
Incident Report for Workheld
Resolved
This incident has been resolved.
Posted Feb 08, 2024 - 09:30 CET
Update
We are continuing to work on a fix for this issue.
Posted Feb 08, 2024 - 09:01 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 08, 2024 - 09:01 CET
Investigating
We are currently investigating this issue.
Posted Feb 08, 2024 - 08:35 CET
This incident affected: Workheld Flow (Workheld Flow Web App) and Workheld Call (Workheld Call Web App).